Beginner ASP.Net / SQL Server security issues – Education Career Blog

Okay, this may be involved…

Anyway, I am trying to learn how to use ASP.Net.

The environment is like this:

  • Windows 7 Professional
  • Visual Studio 2010
  • SQL Server 2008 Developer Edition

I am trying to follow the article here:

Developing and Unit Testing an ASP.NET MVC 2 Application – CodeProject

So far, I have installed IIS, IIS7 Manager, SQL Server and have built the solution from the article successfully.

Then, I created a limited rights user on Windows 7 and added that user to the authorized users in the SQL Server Management Studio.

After much trial / error, I can successfully connect to the (attached) database in the solution folder from the article. This was confirmed by running cmd.exe as the test user and connecting to the SQL server.

Now, when I publish the app to the “X:\inetpub\wwwroot\~user\site” directory, the page loads and looks similar to that shown in the CodeProject article here:

Patient Maintenance Screenshot – CodeProject

Except that I do not have any records shown between the “Patient Maintenance & Search” box and the “Patient Information” box. When I enter info into the query boxes and submit, the results page only shows “no records found”. Clicking the “Save” or “Reset” button does nothing in Firefox.

So, I fire up IExplorer and attempt the same. This time, the error icon indicates that there are “missing objects” or “expected objects”…

Anyway, I then go to the IIS7 Manager and change the “Anonymous Authentication”\”Anonymous user identity” to the test user.

As that does nothing for me, I then open “Authentication\Basic Settings…” and change the “Connect As…” user to the test user and successfully test the connection.

Reloading the page in the browser this time results in the Server Error: “The current identity (MachineName\UserName) does not have write access to ‘X:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files’.”

So, I go to change the permissions on that folder, but decide to pause because I am really frustrated. After finally getting everything installed / updated this morning / afternoon – I took a nice nap… then got up and started on it again, but not so well…

But, now I fear that I may be headed down a wormhole. I don’t want to continue beating my head against this and (probably) going about this the wrong way.

So, does anyone have any good links to blogs / tutorials that deal with a step by step approach to setting up an ASP.net site?

TIA

,

Add the account to IIS_USRS and see if that helps. If by chance, that doesn’t help, you will need to download a utility called process monitor.

Link

http://technet.microsoft.com/hi-in/sysinternals/bb896645.aspx

Leave a Comment