c# – How to use Excel Interop on lower version (.Net)? – Education Career Blog

In C#, I’m using the Microsoft.Office.Interop.Excel reference v12.0.0.0, which (I think) corresponds to Office 2007.

I guess that my program won’t run on computers without Office 2007 or above ? What should I do ?

,

Use late binding and write your code to only use features available in the lowest version that you want to support.

If you don’t know the difference between late and early binding, this article should be useful: Binding for Office automation servers with Visual C# .NET

,

INFO: Develop Microsoft Office solutions with Visual Studio .NET

Writing Automation clients for multiple Office versions

Leave a Comment