python – build recent numpy on recent ubuntu – Education Career Blog

How do I build numpy 1.5 on ubuntu 10.10?
The instructions I found seems outdated or not clear.

Thanks

,

One way to try, which isn’t guaranteed to work, but worth a shot is to see if uupdate can sucessfully update the package. Get a tarball of numpy 1.5. run “apt-get source numpy” which should fetch and unpack the current source from ubuntu. cd into this source directory and run “uupdate ../numpytarballname”. This should update the old source package using the newer tarball. then you can try building with “apt-get build-dep numpy” and “dpkg-buildpackage -rfakeroot”. This will require you have the build-essential and fakeroot packages installed.

,

I used pip to install after getting the required compiler/build tools:

sudo apt-get -y install build-essential
wget http://python-distribute.org/distribute_setup.py && sudo python ./distribute_setup.py
sudo easy_install pip
sudo pip install numpy

I used easy_install to get pip and then pip to get numpy.

Leave a Comment